Really sorry to have to ask this (noob!).. wheres the www gone


DrWebber
 Share

Recommended Posts

How do I get the www visible for my domain...??? :o

I know its not really necessary, and if you type it as part of the address, it gets redirected to my domain, but just curious to know why the url appears as http://mydomain.com and not http://www.mydomain.com...

With our services it should work by default by technically speaking if you're running your own DNS servers you have to create an "A" entry for "www.yourdomain.com".

Link to comment
Share on other sites

  • 3 weeks later...
Apparantly this has been checked.. and is fine... but my site still does not show as www.mydomain.com.. I know its nothing major, Im just curious to know why this is, and how it can be resolved...

when I try to go to my blog, www.mydomain.com/blog, it shows as http://mydomain.com/blog

Thanks

Wordpress redirects to just one url. So if you specify it as just mydomain.com/blog/ then it's going to make anything else that goes to it's folder redirect as such. This is so there is not duplicate content for search engines. So it sounds like www. works fine on your site which makes sense our system automatically adds DNS and web server entries. It's just the fact your software is redirecting to one url.

Link to comment
Share on other sites

when I try to go to my blog, www.mydomain.com/blog, it shows as http://mydomain.com/blog

I'm assuming you're using WordPress for your blog. In order to display as http://www.mydomain.com/blog, you need to:

1) Log into http://mydomain.com/blog/wp-login.php and click on Settings

2) Change the WordPress address (URL) and Blog address (URL) to include www i.e. http://www.mydomain.com/blog

3) Click on Save Changes (you will get some warning messages here due to www inclusion but that's ok.) - your changes will be saved despite the warning messages.

4) Clear your browser's cache.

When you enter http://mydomain.com/blog or http://www.mydomain.com/blog, it will now show as http://www.mydomain.com/blog

Edited by speedturtle
Link to comment
Share on other sites

but my site still does not show as www.mydomain.com..

In order for your site to show as http://www.mydomain.com/, you need to create a .htaccess file in your domain root folder with the following contents:

Options +FollowSymlinks

RewriteEngine On

RewriteCond %{HTTP_HOST} ^mydomain.com$ [NC]

RewriteRule ^(.*)$ http://www.mydomain.com/$1 [R=301,L]

Do this after you have fixed the WordPress settings.

Actually, it's a good idea to display www in front of the domain name (google & amazon do it) and you need to be consistent whenever you refer to your Urls. You can read more about "canonical issue" by googling it.

CNAME and 301 redirect do not do the same thing. CNAME and A records are part of the DNS system, while 301s are part of the HTTP protocol.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share