habari


neqn
 Share

Recommended Posts

Has anyone ever tried to install Habari on a shared account? Seems like some interesting software.

I tried, but was receiving a 404 error when the installer tried to connect to the database to verify everything was OK -- I double-checked passwords and everything -- I'm thinking it might be related to permissions of some sort, or it might be that it's Litespeed and not Apache. I'll have to do some more digging, but I'm just curious if anyone's installed it successfully on the shared account.

Just curious, that's all. Just wanted to try it out, it sounds like an interesting software program.

Link to comment
Share on other sites

Did you use the hostname 'localhost' for MySQL? I just uploaded their requirement checker (found here: http://wiki.habariproject.org/en/Installation#Server_Requirements) and verified the server had all the requirements so it should work.

If you can't figure out the error after digging around you can contact our helpdesk support team and we can take a look :)

Link to comment
Share on other sites

Yeah, I used localhost. I have a feeling it might have something to do with Litespeed vs Apache.

I tried the predefined configuration method too, where you upload the config.php file with all the database info so the installer doesn't ask you for it, and I got an error page that it couldn't connect to the database -- couldn't even get to the installer. I know it needs the PDO for whatever database that is (MySQL, SQLite, PostrgeSQL), and I was only just wanting to try it out, I don't really NEED it or anything, so I didn't want to bother anyone too much about it. The test file passed for me too, but Postgres was greyed out on the installer because there's no PDO. I saw something about that in another thread here, I tried MySQL, which wasn't greyed out, so PDO is probably enabled on that, so I doubt Postgres would work either even if PDO were enabled on it.

I went ahead and installed Wordpress for now, but I'll keep digging around see if I can figure it out. Best I can imagine is that it's got something to do with Litespeed in a shared environment and how it handles certain newer object oriented stuff. It's appears to work at a number of shared hosts, but I believe they run Apache, so that might be it. It's all a work in progress, it's probably only a matter of time.

No biggie, I don't absolutely need it or anything, I just thought I'd try it out -- seems like a nice piece of software.

Link to comment
Share on other sites

Litespeed is just the web server it has nothing to do with PHP. So whether it's PHP 5.2, 5.3 or 6.0 or whatever it won't make a difference to it. Usually 404 errors are due to mod_rewrite rules so the script has you add them or has it htaccess.txt and wants you to rename it .htaccess. We rarely run into issues with scripts not working and when we do it's usually ones that are extremely old using Apache features not even recommended by them anymore.

Link to comment
Share on other sites

BINGO.

The .htaccess file wasn't being written by the installer for some reason, so I had to upload my own. However, the default .htaccess file on the Habari installation wiki has a line that says "RewriteBase /" -- what I had to do was to change that line to the subdirectory (e.g.) "RewriteBase /Habari" that I was installing it into.

It's up and running, so far, so good. Looks like a pretty decent piece of software.

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share