Installing Ocaml via SSH


edwinbradford
 Share

Recommended Posts

Hi Hawk Host,

I have SSH up and running fine now via Putty on Windows, cool. I'm following a guide here on how to install Unison, a backup and sync tool I've been using locally. The first part works fine

$ curl -O http://caml.inria.fr/pub/distrib/ocaml-3.10/ocaml-3.10.1.tar.bz2

$ tar jxvf ocaml-3.10.1.tar.bz2

$ cd ocaml-3.10.1

but it falters when I get to the line
$ ./configure -prefix ~
The returned output is
Configuring for a x86_64-unknown-linux-gnu ...

gcc found

Unable to compile the test program.

Make sure the C compiler gcc -O  is properly installed.

I posted more info at linuxquestions.org but haven't had a response yet so thought I'd try you guys in case you know straight away what the reason is or have some protection enabled that would stop this from working.

Very grateful for any ideas.

Link to comment
Share on other sites

OK that was fixed straight away via a support ticket as expected :D

Next I ran OCaml and got an out of memory error message:

Fatal error: out of memory
I posted on the Unison User Group (don't know if you need a login there) and had some really helpful feedback, the gist is they're saying its common for web hosts to limit memory and suggested running:
ulimit -v
or
ulimit -m

...which returned 200,000 (200MB) so I'm guessing that's the cause of the error.

Can you let me know if that memory cap can be released but I'm assuming not. In which case they've suggested I run a virtual machine and compile locally then just upload the pre-compiled binary. Which CentOS release version are you running, I inadvertently came across the Hawk Host blog and I think its CentOS 5 but I might as well get the release iteration 5.x.

Thanks guys.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share