"www" causing problems with FF4 and IE9


woodp
 Share

Recommended Posts

OK, this one has me stumped - I bought a domain and established hosting here (shared hosting). But I'm getting strange behavior whether I url to the domain.com or www.domain.com ...

http://ontheroadagainbikeshop.com -> Resolves fine in both FF4 and IE9

http://www.ontheroadagainbikeshop.com -> FF4 redirects me to http://www.ontheroadagainbikeshop.com/cgi-sys/defaultwebpage.cgi - Not Good.

IE9 changes the URL to the non-www version (http://ontheroadagainbikeshop.com) and then resolves it just fine.

I've double-checked at my registrar, WHM and CPANEL and can't figure out what I may have done wrong. Any thoughts?

Link to comment
Share on other sites

OK, this one has me stumped - I bought a domain and established hosting here (shared hosting). But I'm getting strange behavior whether I url to the domain.com or www.domain.com ...

http://ontheroadagainbikeshop.com -> Resolves fine in both FF4 and IE9

http://www.ontheroadagainbikeshop.com -> FF4 redirects me to http://www.ontheroadagainbikeshop.com/cgi-sys/defaultwebpage.cgi - Not Good.

IE9 changes the URL to the non-www version (http://ontheroadagainbikeshop.com) and then resolves it just fine.

I've double-checked at my registrar, WHM and CPANEL and can't figure out what I may have done wrong. Any thoughts?

This sounds like a cache issue - if you visitited the website before the DNS resolved in one browser then visited in another once it resolved it may act goofy. I'm unable to replicate this so I suspect you'll be able to clear your cache / history and it'll work fine.

If you're still experiencing please submit a ticket to our support department (https://support.hawkhost.com).

Link to comment
Share on other sites

This sounds like a cache issue - if you visitited the website before the DNS resolved in one browser then visited in another once it resolved it may act goofy. I'm unable to replicate this so I suspect you'll be able to clear your cache / history and it'll work fine.

If you're til experiencing please submit a ticket to our support department (https://support.hawkhost.com).

Cody,

Thanks for the response - You may have been right about cache/propagation on IE9. After resetting the browser, it now behaves as FF4 - Even if I put www.ontheroadagainbikeshop.com in the address bar, it rewrites itself to ontheroadagainbikeshop.com (without the www). I was also able to duplicate this on a Mac/Safari and Mac/FF4. That's four browsers that do the exact same thing.

There's a setting in Drupal to force all www or non-www URLs so I'm familiar with the condition - I've just never seen it in Wordpress sites before.

I'm hesitant to submit a ticket because I really don't think this is a Hawkhost issue - It has to be something with Wordpress or my registrar. I'm just posting here to see if anyone else has seen this problem ...

Link to comment
Share on other sites

I'm hesitant to submit a ticket because I really don't think this is a Hawkhost issue - It has to be something with Wordpress or my registrar. I'm just posting here to see if anyone else has seen this problem ...

Operator error!

On Wordpress' Settings | General page I inadvertently used the www version for the "Wordpress Address" and the non-www version for the "Site Address." Changed them both to www and everything works fine!

<slamming fist on forehead>Can't believe I missed that!</slamming fist on forehead>

Link to comment
Share on other sites

Glad to hear you figured this one out! These things can be frustrating :angry:

I'm hesitant to submit a ticket because I really don't think this is a Hawkhost issue - It has to be something with Wordpress or my registrar. I'm just posting here to see if anyone else has seen this problem ...

Don't feel like you can't contact us for something like this. We try to be extremely available to our users for any problem, and as a result we actually expect to work with you guys on even the smallest (or most trivial) issues. Bottom line being we're not afraid to help so don't be afraid to ask :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share