Wordpress php.ini settings


Recommended Posts

As best I can tell, the default php settings at Hawkhost are

upload_max_filesize = 50M ;

post_max_size = 8M ;

Wordpress uses these to determine whether or not to accept a file for upload. If you upload anything under 8M, no problem; but a 9M file results in an error that max upload size is 50M. Huh?

Turns out that Wordpress expects post_max_size to be larger than upload_max_filesize and when it reports an error, it reports it as being larger than upload_max_filesize, even though it's really only larger than post_max_size. I got around this problem by uploading the following php.ini to the /public_html/wordpress/wp-admin subdirectory:

upload_max_filesize = 20M ;
post_max_size = 25M ;

Today I tried to upload a 14M file and got another error that my file was larger than 50M. I guess my php.ini file is overlooked and php has defaulted back to the system settings. Litespeed? Or a new version of php?

Anyone else having this problem with Wordpress? What's your workaround?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.