Using SSL with email


32209
 Share

Recommended Posts

I am a new HawkHost Shared hosting customer.

When I "check mail" from one of the email addresses on my HawkHost account, using Thunderbird, I must "OK" the following alert BEFORE I can check my HawkHost mail: "You have attempted to establish a connection with 'mail.newhawkhostcustomer.com'. However, the security certificate presented belongs to '*****.***********.com'..."

I understand clearly what the alert is telling me. I would like to know if, and how, I can avoid the alert by merely changing email account settings.

This same alert occurred with my previous host as well. I am, of course, trying to use SSL for my email. Should I change email settings in Thunderbird or cPanel or is this alert appropriate and unavoidable?

I did spend some time trying various port and server settings for the involved email accounts via Thunderbird; however, the result was usually that the email failed so I must have done something wrong.

Primarily I want to be certain that I am using SSL with my HawkHost email accounts if that is available to me and I would prefer not to encounter the above described alert if its occurrence is merely due to incorrect settings that I am using.

my current Thunderbird settings are:

Server Type: POP Mail Server

Server Name: mail.newhawkhostcustomer.com {Port: 995 - default 995}

Security Settings: SSL {not using secure authentication here because it made the email fail}

Security - Digital Signing - nothing selected

Security - Encryption - nothing selected

Outgoing Server (SMTP) - mail.newhawkhostcustomer.com {Port: 465 - secure connection SSL}

note: There is a third party SSL certificate and dedicated IP associated with the hosting account.

Edited by 32209
Link to comment
Share on other sites

The SSL certificates on hosting accounts are used just for the web server and are not part of other services like POP3 and SMTP. The only way around this error is to use the servers hostname which is actually what is suggested by cPanel on the configure page. Each of our machines the hostname has a valid SSL certificate to avoid errors like this.

Link to comment
Share on other sites

...use the servers hostname... Each of our machines the hostname has a valid SSL certificate to avoid errors like this.

You mean set the incoming and outgoing mailservers, both, to *****.***********.com in Thunderbird, or whatever email application I am use?

So anywhere in the email account settings in Thunderbird that requires a server I should use '*****.***********.com' ...

Like this?

my current Thunderbird settings are:

Server Type: POP Mail Server

Server Name: *****.***********.com {Port: 995 - default 995}

Security Settings: SSL {not using secure authentication here because it made the email fail}

Security - Digital Signing - nothing selected

Security - Encryption - nothing selected

Outgoing Server (SMTP) - *****.***********.com {Port: 465 - secure connection SSL}

Link to comment
Share on other sites

You mean set the incoming and outgoing mailservers, both, to *****.***********.com in Thunderbird, or whatever email application I am use?

So anywhere in the email account settings in Thunderbird that requires a server I should use '*****.***********.com' ...

Like this?

my current Thunderbird settings are:

Server Type: POP Mail Server

Server Name: *****.***********.com {Port: 995 - default 995}

Security Settings: SSL {not using secure authentication here because it made the email fail}

Security - Digital Signing - nothing selected

Security - Encryption - nothing selected

Outgoing Server (SMTP) - *****.***********.com {Port: 465 - secure connection SSL}

Yep for the server use the servers hostname whatever it may be.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share