svn checkout?


kingmoore
 Share

Recommended Posts

So I have created an svn repository here: /home//svn/repo

I have done this before, so I kindof know what I'm doing, but I'm no expert. Now , I am able to do a checkout locally in my shared hosting account by doing something like:

svn co file:///home//svn/repo

that works in my shared hosting account, but I want to be able to do a checkout from other environments... namely my home PC. I think I *should* be able to do something like this:

svn co http:///home//svn/repo

But I am getting this error:

svn: PROPFIND request failed on '/home//svn/repo'

svn: PROPFIND of '/home//svn/repo': 405 Method Not Allowed ()

Little help on what I need to do to checkout from a remote host? thanks.

Edited by kingmoore
Link to comment
Share on other sites

I think I choose some bad wording for the page. But what I am talking about is if you go to the rvskin page then the subversion and trac manager page. You'll see a link to and on that page to Subversion Management it'll have something like this on it:

The repository location : svn://domain.com, port 3690 (default).

So just the domain is required in order to login. There is no need to use paths the custom subversion server figures that all out based on the domain you specify.

Link to comment
Share on other sites

Yeah you need to set it up via the SVN and trac manager because it uses a modified subversion server. So I am not how exactly you could connect to it if you created it yourself via the command line. Especially when it hard codes where the repository directory should be based off of the domain you connected to.

Link to comment
Share on other sites

Okay thanks Tony. You have been very helpful. For anyone reading allong, here is how I got things working:

- deleted the repo that I had created by command line

- from cpanel change my theme to RVSkin (this seems to be the only way to get the SVN/Trac manager option)

- go to SVN/Trac Manager and enable/install it

- a default repository is created, I added a sub repo called repo

- from my local machine i get a command prompt, go to the directory that i want in my repo and do this: svn import -m "initial commit" svn:///repo

- to checkout the code I can now do: svn co svn:///repo

The only annoying bit is that when I am SSHed into my hawkhost account, doing svn commands gives me:

svn: error while loading shared libraries: libdb-4.6.so: cannot open shared object file: No such file or directory

So I have to explicitly type /usr/bin/svn to get to the working version of svn. Adding this to my path doesn't seem to help.

Link to comment
Share on other sites

Okay thanks Tony. You have been very helpful. For anyone reading allong, here is how I got things working:

- deleted the repo that I had created by command line

- from cpanel change my theme to RVSkin (this seems to be the only way to get the SVN/Trac manager option)

- go to SVN/Trac Manager and enable/install it

- a default repository is created, I added a sub repo called repo

- from my local machine i get a command prompt, go to the directory that i want in my repo and do this: svn import -m "initial commit" svn:///repo

- to checkout the code I can now do: svn co svn:///repo

The only annoying bit is that when I am SSHed into my hawkhost account, doing svn commands gives me:

svn: error while loading shared libraries: libdb-4.6.so: cannot open shared object file: No such file or directory

So I have to explicitly type /usr/bin/svn to get to the working version of svn. Adding this to my path doesn't seem to help.

Thanks for posting this as I'm sure numerous people will find it helpful.

The reason behind the library error is simply because your account is in a jailed shell (chroot) - so it can't find the system libraries.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share