tradiart

Enable Object Cache in WordPress with Redis

Recommended Posts

Hello! Can you please confirm which settings should we use in order to enable Object Cache in our WordPress sites with Redis?

Following these instructions (https://blog.hawkhost.com/2017/10/20/introducing-cpanel-application-manager-redis-support/), in our HawkHost CPanel:

  • Server Application Manager -> Redis enabled.
  • PHP Selector | extensions -> Redis active.

In our WordPress plugins, I have set up these settings:

  • Method: Redis
  • Host: /home/ourusername/.applicationmanager/redis.sock
  • Port: 0 (As HawkHost uses UNIX)
  • Default Object Lifetime: 360 seconds
  • Password: (leave blank)
  • Redis Database ID: 0

Also these options enabled:

  • Persistent Connection: ON
  • Store Transients: ON

I have tested with https://wordpress.org/support/plugin/litespeed-cache/ and https://wordpress.org/plugins/redis-cache/. But with both, right now I'm getting that Redis Extension: Disabled/Not Found, so any assistance would be really appreciated. Many thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now