YKdvd

Python version

Recommended Posts

I noticed that (at least on Titan) the installed version of Python is 2.4.3, which is pretty long in the tooth - I would have expected 2.7 or at least 2.6.  Is this one of those "a newer version would break more than it gains" things, or just what comes along with your underlying Linux distro?

Share this post


Link to post
Share on other sites

I noticed that (at least on Titan) the installed version of Python is 2.4.3, which is pretty long in the tooth - I would have expected 2.7 or at least 2.6.  Is this one of those "a newer version would break more than it gains" things, or just what comes along with your underlying Linux distro?

 

Hello,

 

The server you're on is RHEL5 which has Python 2.4.x as its primary version (security fixes being backported). If you require newer versions please submit a ticket (please reference this forum thread when doing so), ask for the ticket to be assigned to me (Cody) and we'll be more than happy to install it on the side.

Share this post


Link to post
Share on other sites

It should be fine for now - I've got a ticket in to see if I can get Mercurial set up, and I think it still supports 2.4.  I probably won't need to do any Python of my own, but if I ever do I may take you up on this... :)

 

Just out of curiosity, do you and your LiteSpeed setup support Python WSGI web apps (like Apache's mod_wsgi)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now